cdelafuente-r7 (21)

Last Login: June 25, 2020
Assessments
7
Score
21

cdelafuente-r7's Contributions (7)

Sort by:
Filter by:
1
Ratings
  • Attacker Value
    Very High
  • Exploitability
    Medium
Technical Analysis

This vulnerability affects Ignition 7 (prior to v7.9.14) and 8 (prior to v8.0.10), an Integrated Software Platform for SCADA systems to do cross-platform web-based deployment. These versions contain multiple vulnerabilities that, when chained together, can lead to preauth remote code execution with SYSTEM user privileges (advisory).

CVE-2020-10644 is one of these vulnerabilities (see also CVE-2020-12004) and is related to an input validation issue that leads to deserialization of untrusted data. By sending a request to the /system/gateway API endpoint and invoking getDiffs() action with a specially crafted payload, it is possible to bypass the validation routine and execute arbitrary code remotely.

This vulnerability is rated as critical, but to successfully exploit this, this must be chained with the two other vulnerabilities, as explained above and in the advisory. A Metasploit module exploiting these vulnerabilities is available here

1
Ratings
  • Attacker Value
    Medium
  • Exploitability
    Medium
Technical Analysis

This vulnerability affects Ignition 7 (prior to v7.9.14) and 8 (prior to v8.0.10), an Integrated Software Platform for SCADA systems to do cross-platform web-based deployment. These versions contain multiple vulnerabilities that, when chained together, can lead to preauth remote code execution with SYSTEM user privileges (advisory).

CVE-2020-12004 is one of these vulnerabilities (see also CVE-2020-10644) and is related to an access control issue that enables an attacker to retrieve sensitive information. The com.inductiveautomation.ignition.gateway.servlets.gateway.functions.ProjectDownload Java class provides several actions that do not require authentication. Particularly one of them, getDiffs(), can be used to access all the project data.

This is a medium risk issue when taken alone. However, as explained above, it can be critical when chained with other vulnerabilities.

3
Ratings
Technical Analysis

The installer component of Cisco AnyConnect Secure Mobility Client for Windows prior to 4.8.02042 is vulnerable to path traversal and allows local attackers to create/overwrite files in arbitrary locations as the SYSTEM user. By successfully exploiting this flaw, a local attacker will be able to execute arbitrary commands with elevated privileges and take full control of the system.

This write-up provides some additional information about practical exploitation than the original advisory. Basically, the attack consists of sending a specially crafted IPC message to the TCP port 62522 on the loopback device, which is exposed by the Cisco AnyConnect Secure Mobility Agent service. This service will then launch the vulnerable installer component (vpndownloader), which copies itself to an arbitrary location before being executed with SYSTEM user privileges. Combining this flaw with DLL hijacking technique, it is possible to execute arbitrary code in the context of the SYSTEM user.

Since two PoC’s (here and here ) and a weaponized Metasploit module are now available, it is highly recommended to update AnyConnect.

2
Ratings
Technical Analysis

This vulnerability enables attackers to break the security boundaries that an Active Directory forest claims to maintain. This is due to a flaw in Kerberos and forest trusts themselves. No details were disclosed so far, but the author (@_dirkjan) is going to talk about it at Blackhat Asia later this year (if Mr. Covid lets it happen).

This issue reminds me of this attack disclosed in 2018, which also targets Active Directory forest security boundaries. This leads to a complete compromise of resources in any forest with a two-way interforest trust. According to Microsoft advisory, the severity of @_dirkjan’s vulnerability is only rated as Important. If the level of compromise is similar than 2018’s attack, I believe it is much more critical.

2
Ratings
  • Attacker Value
    Medium
  • Exploitability
    Very High
Technical Analysis

This vulnerability only exists if the High Availability (HA) service of Cisco Smart Software Manager On-Prem is enabled, which is not by default. This service enables an attacker to authenticate using a high-privilege default account with a static password (hardcoded). This attack could be executed by anyone without any specific skills, all he has to do is to authenticate using the default password, and no valid login is even required.

This looks like a critical vulnerability, since you can have access (read and write) to the system’s data and change configurations. However, it looks like the level of privileges would not grant access to the sensitive parts of the system. So, that said, and considering the affected service is not enabled by default, it does not look that critical.

This requires more investigation to understand what can be done with this level of privileges. I did a very quick search on the internet and was not able to find this default password. Some patch reversing might need to be done to find it and start investigating.

1
Ratings
Technical Analysis

This is a privilege escalation vulnerability in Windows Installer and, since the proof of concept is public, this is considered as important.

The issue is due to an incorrect impersonation when setting the DACLs and writing to a file. Windows Installer performs these operations with SYSTEM privileges, even if started by an unprivileged user. By creating the proper symbolic links and winning a race condition, it is possible to take full control of any restricted file and escalate privileges.

Note that the current PoC is not weaponized, but it won’t take too long to add the proper payload.

4
Ratings
  • Attacker Value
    Low
  • Exploitability
    Very High
Technical Analysis

This plugin has approximately 1000 active installations and 24,816 downloads according to Wordpress. The vulnerable versions are approximately 25% of the active installations, which is not that much. Also, the attacker needs to be authenticated with a privileged account to make it exploitable, which reduce the likelihood of exploitation. However, the vulnerability is very easy to exploit: a simple HTTP POST request with a specially crafted ip parameter:

curl -b '<your_session_cookie>;' \
     -d 'ip=127.0.0.1|cat%20/etc/passwd&lookup=Lookup&submit=Submit%20request' \
     'http://my_wordpress.com/wp-admin/admin.php?page=plainview_activity_monitor&tab=activity_tools'

The root cause is a call to exec() with concatenation of unsanitized input (activities_overview.php:357):

exec( 'dig -x ' . $ip, $output );