Attacker Value
(0 users assessed)
(0 users assessed)
User Interaction
Privileges Required
Attack Vector


Disclosure Date: March 25, 2021
Add MITRE ATT&CK tactics and techniques that apply to this CVE.


The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a “purpose” has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named “purpose” values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Add Assessment

No one has assessed this topic. Be the first to add your voice to the community.

CVSS V3 Severity and Metrics
Base Score:
7.4 High
Impact Score:
Exploitability Score:
Attack Vector (AV):
Attack Complexity (AC):
Privileges Required (PR):
User Interaction (UI):
Scope (S):
Confidentiality (C):
Integrity (I):
Availability (A):

General Information


  • fedoraproject,
  • freebsd,
  • mcafee,
  • netapp,
  • nodejs,
  • openssl,
  • oracle,
  • sonicwall,
  • tenable,
  • windriver


  • capture client,
  • cloud volumes ontap mediator -,
  • commerce guided search 11.3.2,
  • email security,
  • enterprise manager for storage management,
  • fedora 34,
  • freebsd 12.2,
  • graalvm 19.3.5,
  • graalvm,
  • graalvm,
  • jd edwards enterpriseone tools,
  • jd edwards world security a9.4,
  • linux -,
  • linux 17.0,
  • linux 18.0,
  • linux 19.0,
  • mysql connectors,
  • mysql enterprise monitor,
  • mysql server,
  • mysql workbench,
  • nessus,
  • nessus agent,
  • nessus network monitor 5.11.0,
  • nessus network monitor 5.11.1,
  • nessus network monitor 5.12.0,
  • nessus network monitor 5.12.1,
  • nessus network monitor 5.13.0,
  • node.js,
  • oncommand workflow automation -,
  • ontap select deploy administration utility -,
  • openssl,
  • peoplesoft enterprise peopletools,
  • santricity smi-s provider firmware -,
  • secure backup,
  • secure global desktop 5.6,
  • sma100 firmware,
  • sonicos,
  • storagegrid -,
  • storagegrid firmware -,
  • web gateway 10.1.1,
  • web gateway 8.2.19,
  • web gateway 9.2.10,
  • web gateway cloud service 10.1.1,
  • web gateway cloud service 8.2.19,
  • web gateway cloud service 9.2.10,
  • weblogic server,
  • weblogic server



Additional Info

Technical Analysis


When strict certificate chain checks are enabled (which is not the default configuration) it is possible for an attacker to bypass these checks. X509_V_FLAG_X509_STRICT must be set and either no purpose configured or the default purpose is overriden.

OpenSSL versions 1.1.1h and newer are affected. The fix is available in OpenSSL 1.1.1k.

OpenSSL 1.0.2 is not affected.


Organizations that develop products or services that utilize OpenSSL should integrate the fixes as soon as possible.

Organizations that use products that have embedded OpenSSL should monitor their vendor patch releases to see if they are affected and patch according to your normal priority patch window cycle unless you are running very sensitive applications in need of a very high level of CA assurance (CVE-2021-3450) or have internet-facing systems that could be targeted with hard-to-detect application-level denial-of-service attacks (CVE-2021-3449)