Attacker Value
High
(1 user assessed)
Exploitability
Very High
(1 user assessed)
User Interaction
None
Privileges Required
Low
Attack Vector
Local
0

CVE-2019-17388

Disclosure Date: March 28, 2019
Add MITRE ATT&CK tactics and techniques that apply to this CVE.

Description

Weak file permissions applied to the Aviatrix VPN Client through 2.2.10 installation directory on Windows and Linux allow a local attacker to execute arbitrary code by gaining elevated privileges through file modifications.

Add Assessment

1
Ratings
Technical Analysis

VPN clients are commonly found on laptops for remote office workers, This is a local priv esc on all Aviatrix VPN Clients. As it is local it would need either a malicious user or an attacker with User level access looking to escalate.

Due to file permissions on scripts that are executed to start and stop the VPN client, it is trivial to inject arbitrary OS commands that can be used to escalate privs.

https://immersivelabs.com/2019/12/04/aviatrix-vpn-client-vulnerability/

General Information

Additional Info

Technical Analysis